APP Mod Hey+ App

Joined
Apr 13, 2019
Messages
5
Likes
0
Points
6
Viber notifications are not working at all, maybe because that "new message" filter or do you know why? :(
Also one more thing I noticed "Hear rate" measurements are not displayed correctly over time, they are -8 hours for me (little China time zone problem again).
Both "Walk" and "Sleep" times are correct. Besides that, everything is as it should be I think. Thank you one more time! Best regards
 

MagicalUnicorn

Moderator
Staff member
Moderator
Contributor
Joined
Jul 4, 2018
Messages
2,264
Likes
1,830
Points
158
Viber notifications are not working at all, maybe because that "new message" filter or do you know why? :(
Also one more thing I noticed "Hear rate" measurements are not displayed correctly over time, they are -8 hours for me (little China time zone problem again).
Both "Walk" and "Sleep" times are correct. Besides that, everything is as it should be I think. Thank you one more time! Best regards
Same filters since Hey Plus 1.1.6.0. If when you received Viber notifications the content was empty, with filters the notification isn't send at smartband.

For Heart Rate I know the problem and I already reported it.
Heart rate is calculated like that :
Heart rate hour = Your GMT - (GMT+08 - Your GMT).
 

matt123337

New member
Joined
May 8, 2019
Messages
4
Likes
1
Points
1
Hey I flashed the latest firmware for English, and it's in English, just a bunch of text that should be rendering isn't. Like all of the settings page is blank, and some text on the data page. When I delete the custom firmware and reflash the text comes back, but is obviously in Chinese.

Edit:So reflashing doesn't make the text come back, still missing even with the Chinese firmware.
 

Attachments

Last edited:

MagicalUnicorn

Moderator
Staff member
Moderator
Contributor
Joined
Jul 4, 2018
Messages
2,264
Likes
1,830
Points
158
Hey I flashed the latest firmware for English, and it's in English, just a bunch of text that should be rendering isn't. Like all of the settings page is blank, and some text on the data page. When I delete the custom firmware and reflash the text comes back, but is obviously in Chinese.

Edit:So reflashing doesn't make the text come back, still missing even with the Chinese firmware.
Because you had Russian Firmware, I'm sorry but I haven't solution for you.

Have you tried flash latest Russian Firmware and after flash English Firmware ?
 
Joined
May 8, 2019
Messages
4
Likes
1
Points
1
Ok, try flash older firmware version.
So I tried that, still same issue. I contacted the seller I bought it from, and they told me to flash a file called "1.7.19_ENv10.5.zip". I assume this is some variation of the russian firmware, and is there any way to switch to yours?

Edit: Managed to get it switched over, I installed the english apk from the zip file the seller sent me (was also able to find it by just googling the name) and then let it update the stock firmware. Failed the first time, then managed to do it the second time. Then I just followed the instructions for installing your mod and we're in English!
 
Last edited:

Georgerr

New member
Joined
May 13, 2019
Messages
1
Likes
0
Points
1
Hi, I have nfc tag mifare ultralight, from phone it is readed as #0001234567891234, but if I add it to Hey and read it with my reader I got back #0000000001234567... It is possible Add it manualy or can I add it without this zeroes in front?
Thank you
 
Joined
May 14, 2019
Messages
3
Likes
0
Points
1
Hi there! Thanks for the English firmware and app, I received my Hey+ today, flashed the English firmware straight away and installed the English app. However, there appears to be a connectivity issue:

The band will not connect to the phone unless it is literally placed right next to it. Just to give you an idea, if I am wearing it on my wrist and holding the phone with the same hand, it will simply not connect! That renders my band useless for activity tracking using GPS etc.

This is quite weird... Could the band be stuck in a "low power" Bluetooth mode, causing this? I am attempting to re-flash the firmware and reinstall the app, and will comment if there is any success (although I doubt it).

Any ideas?

Thanks!

P.S. Probably irrelevant, but I am using a Samsung Galaxy S8 (G950F)
 

GonzaP6

New member
Joined
May 14, 2019
Messages
2
Likes
0
Points
1
Hello community! I received my hey + a few days ago and I found a flaw in the screen, I can not see the wallpaper or texts, much less icons. I am new here, sorry if I break some rule. Thanks and regards!
 
Last edited by a moderator:

MagicalUnicorn

Moderator
Staff member
Moderator
Contributor
Joined
Jul 4, 2018
Messages
2,264
Likes
1,830
Points
158

MagicalUnicorn

Moderator
Staff member
Moderator
Contributor
Joined
Jul 4, 2018
Messages
2,264
Likes
1,830
Points
158
Hi there! Thanks for the English firmware and app, I received my Hey+ today, flashed the English firmware straight away and installed the English app. However, there appears to be a connectivity issue:

The band will not connect to the phone unless it is literally placed right next to it. Just to give you an idea, if I am wearing it on my wrist and holding the phone with the same hand, it will simply not connect! That renders my band useless for activity tracking using GPS etc.

This is quite weird... Could the band be stuck in a "low power" Bluetooth mode, causing this? I am attempting to re-flash the firmware and reinstall the app, and will comment if there is any success (although I doubt it).

Any ideas?

Thanks!

P.S. Probably irrelevant, but I am using a Samsung Galaxy S8 (G950F)
Really strange problem, have you searched in your Phone Bluetooth parameter if a"low power" option or something like that is enabled ?

Also, try pair your Hey+ with a other smartphone to be sure the problem don't come from the smartband :).
 

Mr_BananaPants

Moderator
Staff member
Moderator
Official Forum Photographer
Joined
Jul 8, 2018
Messages
220
Likes
158
Points
53
It arrived that way and I was hoping it would be fixed with the update but it continues like this. Any idea?
If re-flashing the firmware didn't fix the issue, you probably have a faulty watch. You have to contact the seller.
 
Joined
May 14, 2019
Messages
3
Likes
0
Points
1
Really strange problem, have you searched in your Phone Bluetooth parameter if a"low power" option or something like that is enabled ?

Also, try pair your Hey+ with a other smartphone to be sure the problem don't come from the smartband :).
Thank you for your reply. My phone works flawlessly with other Bluetooth devices, such as speakers etc, from very "healthy" distances, so I highly doubt its something to do with the phone. Disabling all "power-saving" options did not change anything. I will probably try with another phone later on today, but I highly doubt results will be any different.

Re-flashing the firmware did not fix anything, so it might as well be a hardware issue then...

I might have to ship the band back to the seller then, and should have the Chinese firmware to avoid any issues...

Could you please provide me with a flashable version of the Chinese firmware, please? I cannot get it to flash through the original app. (I was pretty stupid not to test the band with its original firmware in advance... but since everything else works flawlessly apart from the Bluetooth, it looks like it was indeed a hardware issue...)

Again, thank you for your help! Looking forward to your reply, the Chinese firmware files would be of great help if that's possible! :)
 

MagicalUnicorn

Moderator
Staff member
Moderator
Contributor
Joined
Jul 4, 2018
Messages
2,264
Likes
1,830
Points
158
Thank you for your reply. My phone works flawlessly with other Bluetooth devices, such as speakers etc, from very "healthy" distances, so I highly doubt its something to do with the phone. Disabling all "power-saving" options did not change anything. I will probably try with another phone later on today, but I highly doubt results will be any different.

Re-flashing the firmware did not fix anything, so it might as well be a hardware issue then...

I might have to ship the band back to the seller then, and should have the Chinese firmware to avoid any issues...

Could you please provide me with a flashable version of the Chinese firmware, please? I cannot get it to flash through the original app. (I was pretty stupid not to test the band with its original firmware in advance... but since everything else works flawlessly apart from the Bluetooth, it looks like it was indeed a hardware issue...)

Again, thank you for your help! Looking forward to your reply, the Chinese firmware files would be of great help if that's possible! :)
Use Hey Plus flash without custom Firmware or Resources in 1.12.74 folder :).
 

Trusted Store

Staff online

Our Telegram Channel

Which color of official strap would you like to buy for your Mi Band 3?

  • Black

    Votes: 969 57.0%
  • Deep Blue

    Votes: 485 28.5%
  • Redish Orange

    Votes: 247 14.5%

Forum statistics

Threads
780
Messages
21,068
Members
112,964
Latest member
Akshaycharla
Top